Package name: apache-beam[gcp]


Self Compatibility Check Results

Python Version Result Details
Py2
success NO DETAILS
Py3
success The package does not support this version of python.

Dependency Check Result: obsolete dependency

Dependency Name Priority to Update Installed Version Latest Version Details
fastavro
LOW_PRIORITY
0.21.24
0.23.0
fastavro is not up to date with the latest version
google-apitools
HIGH_PRIORITY
0.5.28
0.5.30
it has been over 6 months since the latest version for google-apitools was released
google-cloud-bigquery
HIGH_PRIORITY
1.17.1
1.24.0
google-cloud-bigquery is 3 or more minor versions behind the latest version
google-cloud-bigtable
LOW_PRIORITY
1.0.0
1.2.1
google-cloud-bigtable is not up to date with the latest version
google-cloud-datastore
HIGH_PRIORITY
1.7.4
1.11.0
google-cloud-datastore is 3 or more minor versions behind the latest version
google-cloud-pubsub
HIGH_PRIORITY
1.0.2
1.4.2
google-cloud-pubsub is 3 or more minor versions behind the latest version
google-resumable-media
LOW_PRIORITY
0.4.1
0.5.0
google-resumable-media is not up to date with the latest version
googledatastore
HIGH_PRIORITY
7.0.2
7.1.0
it has been over 6 months since the latest version for googledatastore was released
httplib2
HIGH_PRIORITY
0.12.0
0.17.0
httplib2 is 3 or more minor versions behind the latest version
importlib-metadata
LOW_PRIORITY
1.5.0
1.6.0
importlib-metadata is not up to date with the latest version
importlib-resources
HIGH_PRIORITY
1.0.2
1.4.0
importlib-resources is 3 or more minor versions behind the latest version
mock
HIGH_PRIORITY
2.0.0
3.0.5
mock is 1 or more major versions behind the latest version
oauth2client
HIGH_PRIORITY
3.0.0
4.1.3
oauth2client is 1 or more major versions behind the latest version
pyarrow
LOW_PRIORITY
0.15.1
0.16.0
pyarrow is not up to date with the latest version
PyYAML
HIGH_PRIORITY
3.13
5.2
PyYAML is 1 or more major versions behind the latest version
Deprecated Dependencies

oauth2client

Google Compatibility Check Results

Click on the tabs to see results for different Python versions.

Check Result: incompatible

Package Name Details
google-api-python-client
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support apache-beam 2.19.0 has requirement httplib2<=0.12.0,>=0.8, but you have httplib2 0.17.0. googledatastore 7.0.2 has requirement httplib2<=0.12.0,>=0.9.1, but you have httplib2 0.17.0.
google-cloud-storage
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support google-cloud-bigquery 1.17.1 has requirement google-resumable-media<0.5.0dev,>=0.3.1, but you have google-resumable-media 0.5.0.
google-resumable-media
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support google-cloud-bigquery 1.17.1 has requirement google-resumable-media<0.5.0dev,>=0.3.1, but you have google-resumable-media 0.5.0.

Check Result: success

Dependency Name Details