Package name: git+git://github.com/census-instrumentation/opencensus-python.git

Commit number: 346fce37274ad27752a7508df185a87486827754


Self Compatibility Check Results

Python Version Result Details
Py2
success NO DETAILS
Py3
success NO DETAILS

Dependency Check Result: obsolete dependency

Dependency Name Priority to Update Installed Version Latest Version Details
appdirs
HIGH_PRIORITY
1.4.3
1.4.4
it has been over 6 months since the latest version for appdirs was released
distlib
LOW_PRIORITY
0.3.0
0.3.1
distlib is not up to date with the latest version
importlib-metadata
HIGH_PRIORITY
1.6.0
2.1.1
importlib-metadata is 1 or more major versions behind the latest version
importlib-resources
HIGH_PRIORITY
1.4.0
3.3.0
importlib-resources is 1 or more major versions behind the latest version
six
HIGH_PRIORITY
1.14.0
1.15.0
it has been over 6 months since the latest version for six was released
typing
LOW_PRIORITY
3.7.4.1
3.7.4.3
typing is not up to date with the latest version

Google Compatibility Check Results

Click on the tabs to see results for different Python versions.

Check Result: success

Package Name Details

Check Result: incompatible

Dependency Name Details
google-api-core
opencensus 0.8.dev0 has requirement google-api-core<2.0.0,>=1.0.0, but you have google-api-core 2.0.1.
google-api-python-client
google-api-core 1.31.2 has requirement google-auth<2.0dev,>=1.25.0, but you have google-auth 2.0.2.
google-auth
google-api-core 1.31.2 has requirement google-auth<2.0dev,>=1.25.0, but you have google-auth 2.0.2.
google-cloud-core
google-api-core 1.31.2 has requirement google-auth<2.0dev,>=1.25.0, but you have google-auth 2.0.2.