Package name: google-api-python-client


Self Compatibility Check Results

Python Version Result Details
Py2
success NO DETAILS
Py3
success NO DETAILS

Dependency Check Result: obsolete dependency

Dependency Name Priority to Update Installed Version Latest Version Details
appdirs
LOW_PRIORITY
1.4.3
1.4.4
appdirs is not up to date with the latest version
distlib
LOW_PRIORITY
0.3.0
0.3.1
distlib is not up to date with the latest version
importlib-metadata
LOW_PRIORITY
1.6.0
1.7.0
importlib-metadata is not up to date with the latest version
importlib-resources
HIGH_PRIORITY
1.4.0
3.0.0
importlib-resources is 1 or more major versions behind the latest version
six
LOW_PRIORITY
1.14.0
1.15.0
six is not up to date with the latest version
typing
LOW_PRIORITY
3.7.4.1
3.7.4.3
typing is not up to date with the latest version

Google Compatibility Check Results

Click on the tabs to see results for different Python versions.

Check Result: incompatible

Package Name Details
apache-beam[gcp]
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support apache-beam 2.24.0 has requirement httplib2<0.18.0,>=0.8, but you have httplib2 0.18.1.

Check Result: success

Dependency Name Details